| |

Video Quality Evaluation

 March 1, 2011, OTTCon, San Jose, CA– we talked with First Media about their video quality evaluation tools. They believe their tools can improve the quality of experience for viewers by detecting where video stream degradation occurs.

Video delivery requires evaluation of signal quality along the entire distribution channel. Some of these channels include multicast broadcast, unicast – VoD, adaptive streaming, and HTTP streaming. Starting at the beginning of the delivery chain, they insert their CQA box into the video stream to analyze media before encoding and after encoding (before any DRM encryption).


Video Distribution

 

They can analyze live streams, as well as streams captured as files. take input through ASI, SDI interfaces. After analysis of the media quality by means of decoding the media frame by frame, they assesses a number of media quality parameters including blur, block distortion, frozen frames, audio video lip synchronization, jerkiness, and degradation factors. In addition, indicators such as video loss, edge busyness, and quantization noise, are used to create estimates QoE values – MOS-V, MOS-A, MOS-AV, VSPQ, VSAQ, and VSMQ. Among the standards they can address are MPEG2 Transport Stream over IP, over ASI/SDI, video codecs: MPEG2. H.264, MPEG4 and audio codecs: MPEG1 Layer 1,2,and 3, MPEG-2 AAC, and HE-AAC.

In addition, TSA is the Transport Stream Analysis component. It can be deployed at the head end to analyze the on-air stream, or at manned locations in the distribution network such as a video hub office. The box probes the packets flowing through the network and analyzes media quality parameters at the content level (using header information), media stream level as well as transport network level. TSA supports MPEG2 transport stream over RTP (both RFC 2250 and RFC 3611) and MPEG2 transport stream over UDP. It analyzes the captured media at multiple levels using different standards: IP layer, IGMP v2 & v3—latency, RFC 3357—loss period and loss distance, MPEG2 stream level, ISO 13818 TS information—PAT, PMT, CAT, PCR PID, ETSI TR101-290 Priority 1 and 2 parameters, media content level, IPB structure information, RTP loss and jitter, and missed and impaired I, P, and B Frames

Downstream analysis uses other boxes to monitor transmission effects and can even measure quality factors all the way down to the display platform. There are number of different tools for these separate functions. The downstream tools do not perform full measurements, but only compare local content with information about the quality from the head end. Software tools enable browser-based inspection and analysis of video streams.

Similar Posts